Ubuntu 16.04 LTS freeze problem:Freeze while after playing audio or video problem: qjackctl, pulseaudio

OS update wasn’t effective.

Killing qjackctl was effective to solve GUI freeze.

To start from the result upgrade to the latest one solved this.
It involved package manager repository error maybe…

Came back after a while

pulseaudio dependency programs upgrade and low latency kernel upgrade

pulseaudio dependency programs upgrade and low latency kernel upgrade to 4.15.0-47-lowlatency solved the problem finally. to 4.4.0-145-lowlatency is better. 4.15 version has error, jack sound clipping error.

 

I tried

sudo apt-get remove --purge qjackctl
sudo apt-get update
sudo apt-get install qjackctl

This made elapse time to freeze longer perhaps but not solved.
My case version not upgraded upper than 0.4.5.

 

masa@em-p:~$ qjackctl -v
Qt: 4.8.7
QjackCtl: 0.4.5

Latest is 0.5.5

I tried to install latest one but not upgraded.

tried download the source and ./configure, make install, but still 0.4.5.

After reboot, upgraded to 0.5.5.

This removed the problem so far…

Case closed!!!

Killing process launching console by

ctrl + alt + F2

and

ps x | grep qjackctl

kill PID(qjackctl)

and back to the GUI by

ctrl + alt + F7

was very plentiful study source for me…

I will write a post about this …

#apt-get #repository #Xdesktop #process

ref
https://github.com/rncbc/qjackctl/issues/13

==================================================================================

error has came back….

When Tried to driver update, apt-get error found.

tried kill pulseaudio

masa@em-p:~$ pulseaudio --kill
masa@em-p:~$ ps x |grep pulse
4512 ? S<l 0:00 /usr/bin/pulseaudio --start --log-target=syslog
4517 pts/17 S+ 0:00 grep --color=auto pulse

Before kill pulseaudio, check the grep result

masa@em-p:~$ pulseaudio --start
masa@em-p:s x |grep pulse
4535 ? S<l 0:00 pulseaudio --start
4541 pts/17 S+ 0:00 grep --color=auto pulse

Checked pulseaudio version

masa@em-p:~$ pulseaudio --version
pulseaudio 8.0

https://www.freedesktop.org/wiki/Software/PulseAudio/

Tried to upgrade pulseaudio. Xenial’s latest is 8.0 but dependency library were upgraded. Also low-latency kernel latest one added.

masa@em-p:~$ sudo apt-get upgrade pulseaudio
[sudo] password for masa: 
Reading package lists... Done
Building dependency tree 
Reading state information... Done
pulseaudio is already the newest version (1:8.0-0ubuntu3.10+kxstudio1).
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
linux-headers-4.15.0-43 linux-headers-4.15.0-43-generic
linux-image-4.15.0-43-generic linux-modules-4.15.0-43-generic
linux-modules-extra-4.15.0-43-generic
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
linux-generic-hwe-16.04 linux-headers-generic
linux-headers-generic-hwe-16.04 linux-headers-lowlatency
linux-image-generic-hwe-16.04 linux-image-lowlatency linux-lowlatency
The following packages will be upgraded:
apache2-bin busybox-initramfs busybox-static google-chrome-stable
grub-common grub-efi-amd64-bin grub-pc grub-pc-bin grub2-common
kodi-inputstream-adaptive libpam-systemd libpolkit-agent-1-0
libpolkit-backend-1-0 libpolkit-gobject-1-0 libsmbclient libsystemd0
libsystemd0:i386 libudev1 libudev1:i386 libwbclient0 linux-libc-dev
linux-libc-dev:i386 policykit-1 python-samba rsyslog samba samba-common
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules
systemd systemd-sysv udev
34 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 77.0 MB/80.0 MB of archives.
After this operation, 66.6 kB of additional disk space will be used.
Do you want to continue? [Y/n]

 

Setting up google-chrome-stable (73.0.3683.103-1) ...
Setting up grub-common (2.02~beta2-36ubuntu3.21) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Setting up grub-efi-amd64-bin (2.02~beta2-36ubuntu3.21) ...
Setting up grub2-common (2.02~beta2-36ubuntu3.21) ...
Setting up grub-pc-bin (2.02~beta2-36ubuntu3.21) ...
Setting up grub-pc (2.02~beta2-36ubuntu3.21) ...
cp: cannot remove '/var/lib/ucf/hashfile.7': Read-only file system
rm: cannot remove '/tmp/grub.UniXufaHIw': Read-only file system
debconf: DbDriver "config": could not write /var/cache/debconf/config.dat-new: Read-only file system
dpkg: error processing package grub-pc (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.19) ...
dpkg: unrecoverable fatal error, aborting:
unable to flush updated status of 'libc-bin': Read-only file system
touch: cannot touch '/var/lib/update-notifier/dpkg-run-stamp': Read-only file system
E: Sub-process /usr/bin/dpkg returned an error code (2)
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - pkgDPkgPM::Go (30: Read-only file system)
masa@em-p:~$ pulseaudio --version
pulseaudio 8.0
masa@em-p:~$ sudo apt-get upgrade pulseaudio
W: Not using locking for read only lock file /var/lib/dpkg/lock-frontend
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
masa@em-p:~$

next time upgrade seemed successful.

New kernel added.

check the kernel version.

masa@em-p:~$ uname -r
4.4.0-143-lowlatency

check available kernel versions

sudo apt-cache search linux-image

download latest one from this deb file.

https://packages.ubuntu.com/ja/xenial/amd64/linux-lowlatency-hwe-16.04/download

reboot and select the new one

masa@em-p:~$ uname -r
4.15.0-47-lowlatency

This solved the problem!!!

Next grub configuration to set to default the new kernel.

 

==========================================================

P.S

And another problem. dbus-send error problem. Is this have any relation to freeze error?

masa@em-p:~$ dbus-send --system /org/rncbc/qjackctl org.rncbc.qjackctl.stop
Failed to open connection to "system" message bus: Failed to connect to socket /opt/anaconda2/var/run/dbus/system_bus_socket: No such file or directory

under /opt/anaconda2/var directory only has cache directory, no run directory in my environment.

 

Advertisements